using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^"".*?""";
string substitution = @"";
string input = @"""C:\Windows\system32\NOTEPAD.EXE"" C:\!\inal11404 -дла оощ ыф цумщлзкщл3з мц ацул MNNMMMqpl v23 953 53262v32 - копия (2) - копия.log";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}