const regex = /^".*?"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^".*?"', 'gm')
const str = `"C:\\Windows\\system32\\NOTEPAD.EXE" C:\\!\\inal11404 -дла оощ ыф цумщлзкщл3з мц ацул MNNMMMqpl v23 953 53262v32 - копия (2) - копия.log`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);