package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sUi)\("(?<name>\w+Message)"(,"(\w+Message)")*,function\([\w,]*\){.*?}\)`)
var str = `("aaMessage","sdfsdfMessage","sdfsdfMessage",function(e){})`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}