$re = '/\("(?<name>\w+Message)"(,"(\w+Message)")*,function\([\w,]*\){.*?}\)/sUi';
$str = '("aaMessage","sdfsdfMessage","sdfsdfMessage",function(e){})';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);