// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?sUi)\("(?<name>\w+Message)"(,"(\w+Message)")*,function\([\w,]*\){.*?}\)"#).unwrap();
let string = "(\"aaMessage\",\"sdfsdfMessage\",\"sdfsdfMessage\",function(e){})";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}