re = /\("(?<name>\w+Message)"(,"(\w+Message)")*,function\([\w,]*\){.*?}\)/i
str = '("aaMessage","sdfsdfMessage","sdfsdfMessage",function(e){})'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end