using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'keyValue': ({.+})";
string input = @"Tried to save duplicate unique keys (E11000 duplicate key error collection: test.users index: email_1 dup key: { email: ""amit@email.com"" }, full error: {'index': 0, 'code': 11000, 'errmsg': 'E11000 duplicate key error collection: test.users index: email_1 dup key: { email: ""amit@email.com"" }', 'keyPattern': {'email': 1}, 'keyValue': {'email': 'amit@email.com'}})
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}