use strict;
my $str = 'Tried to save duplicate unique keys (E11000 duplicate key error collection: test.users index: email_1 dup key: { email: "amit@email.com" }, full error: {\'index\': 0, \'code\': 11000, \'errmsg\': \'E11000 duplicate key error collection: test.users index: email_1 dup key: { email: "amit@email.com" }\', \'keyPattern\': {\'email\': 1}, \'keyValue\': {\'email\': \'amit@email.com\'}})
';
my $regex = qr/'keyValue': ({.+})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}