import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'keyValue': (\\{.+\\})";
final String string = "Tried to save duplicate unique keys (E11000 duplicate key error collection: test.users index: email_1 dup key: { email: \"amit@email.com\" }, full error: {'index': 0, 'code': 11000, 'errmsg': 'E11000 duplicate key error collection: test.users index: email_1 dup key: { email: \"amit@email.com\" }', 'keyPattern': {'email': 1}, 'keyValue': {'email': 'amit@email.com'}})\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}