re = /'keyValue': ({.+})/m
str = 'Tried to save duplicate unique keys (E11000 duplicate key error collection: test.users index: email_1 dup key: { email: "amit@email.com" }, full error: {\'index\': 0, \'code\': 11000, \'errmsg\': \'E11000 duplicate key error collection: test.users index: email_1 dup key: { email: "amit@email.com" }\', \'keyPattern\': {\'email\': 1}, \'keyValue\': {\'email\': \'amit@email.com\'}})
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end