// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)'keyValue': ({.+})").unwrap();
let string = "Tried to save duplicate unique keys (E11000 duplicate key error collection: test.users index: email_1 dup key: { email: \"amit@email.com\" }, full error: {'index': 0, 'code': 11000, 'errmsg': 'E11000 duplicate key error collection: test.users index: email_1 dup key: { email: \"amit@email.com\" }', 'keyPattern': {'email': 1}, 'keyValue': {'email': 'amit@email.com'}})
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}