#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?=[02-9]*1[02-9]*1[02-9]*\b)(?=\d{3})\d*7\d*\b"
Local $sString = "1171" & @CRLF & _
"1172" & @CRLF & _
"1173" & @CRLF & _
"1174" & @CRLF & _
"1175" & @CRLF & _
"1176" & @CRLF & _
"1178" & @CRLF & _
"1711" & @CRLF & _
"1712" & @CRLF & _
"1713" & @CRLF & _
"1714" & @CRLF & _
"1715" & @CRLF & _
"1717" & @CRLF & _
"1718" & @CRLF & _
"1719"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")