const regex = /\b(?=[02-9]*1[02-9]*1[02-9]*\b)(?=\d{3})\d*7\d*\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?=[02-9]*1[02-9]*1[02-9]*\\b)(?=\\d{3})\\d*7\\d*\\b', 'gm')
const str = `1171
1172
1173
1174
1175
1176
1178
1711
1712
1713
1714
1715
1717
1718
1719`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}