using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?=[02-9]*1[02-9]*1[02-9]*\b)(?=\d{3})\d*7\d*\b";
string input = @"1171
1172
1173
1174
1175
1176
1178
1711
1712
1713
1714
1715
1717
1718
1719";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}