$re = '/\b(?=[02-9]*1[02-9]*1[02-9]*\b)(?=\d{3})\d*7\d*\b/m';
$str = '1171
1172
1173
1174
1175
1176
1178
1711
1712
1713
1714
1715
1717
1718
1719';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);