import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?=[02-9]*1[02-9]*1[02-9]*\\b)(?=\\d{3})\\d*7\\d*\\b";
final String string = "1171\n"
+ "1172\n"
+ "1173\n"
+ "1174\n"
+ "1175\n"
+ "1176\n"
+ "1178\n"
+ "1711\n"
+ "1712\n"
+ "1713\n"
+ "1714\n"
+ "1715\n"
+ "1717\n"
+ "1718\n"
+ "1719";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}