use strict;
my $str = '.01444
10.454
4.0O0
-1.00
+4.54
SomeRandomStuffand
1.0df0
10.0cv
1.aada
4+1.00254
0.5.0
+9>>10
9.7
1>>3
-2.4
-9<<9
+10.7
+2<<5
5.5
4<<8
-8.5
-7>>9
+9.50
1.h
';
my $regex = qr/^[+-]?\d*?\.\d+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}