import re
regex = re.compile(r"^[+-]?\d*?\.\d+$", flags=re.MULTILINE)
test_str = (".01444\n"
"10.454\n"
"4.0O0\n"
"-1.00\n"
"+4.54\n"
"SomeRandomStuffand\n"
"1.0df0\n"
"10.0cv\n"
"1.aada\n"
"4+1.00254\n"
"0.5.0\n"
"+9>>10\n"
"9.7\n"
"1>>3\n"
"-2.4\n"
"-9<<9\n"
"+10.7\n"
"+2<<5\n"
"5.5\n"
"4<<8\n"
"-8.5\n"
"-7>>9\n"
"+9.50\n"
"1.h\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")