# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=(\s))([0-9]{1,2})\b(?!\s*(:|am|pm|from|to|minutes|minute|min|mins))"
test_str = ("turn the heating on from 5 mins to 1 am until 10 mins to 2pm\n"
"turn the heating on from 1 until 2\n"
"turn the heating on from 5 to 1 until 10 to 2\n"
"turn the heating on from 5 mins to 1 until 10 mins to 2\n"
"turn the heating on from 5 mins to 1 in the the morning\n"
"turn the heating on from 5 mins to 1:00 until 10 mins to 2:00\n"
"turn the heating on from 5 mins to 1:00 until 10 mins to 2\n"
"turn the heating on until 3\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.