import Foundation
let pattern = #"(?<=(\s))([0-9]{1,2})\b(?!\s*(:|am|pm|from|to|minutes|minute|min|mins))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
turn the heating on from 5 mins to 1 am until 10 mins to 2pm
turn the heating on from 1 until 2
turn the heating on from 5 to 1 until 10 to 2
turn the heating on from 5 mins to 1 until 10 mins to 2
turn the heating on from 5 mins to 1 in the the morning
turn the heating on from 5 mins to 1:00 until 10 mins to 2:00
turn the heating on from 5 mins to 1:00 until 10 mins to 2
turn the heating on until 3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)