using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\s*//.*)(*SKIP)(*F)|^(?:\s*Connection\s+)?(.+?)\s*=\s*new\s+DBConnection";
string input = @"Connection variable = new DBConnection
variable = new DBConnection
//
//Connection variable = new DBConnection
//variable = new DBConnection
// Connection variable = new DBConnection
// variable = new DBConnection";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}