const regex = new RegExp('^(\\s*//.*)(*SKIP)(*F)|^(?:\\s*Connection\\s+)?(.+?)\\s*=\\s*new\\s+DBConnection', 'gm')
const str = `Connection variable = new DBConnection
variable = new DBConnection
//
//Connection variable = new DBConnection
//variable = new DBConnection
// Connection variable = new DBConnection
// variable = new DBConnection`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}