import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\s*//.*)(*SKIP)(*F)|^(?:\\s*Connection\\s+)?(.+?)\\s*=\\s*new\\s+DBConnection";
final String string = "Connection variable = new DBConnection\n"
+ "variable = new DBConnection\n"
+ "//\n"
+ "//Connection variable = new DBConnection\n"
+ "//variable = new DBConnection\n"
+ "// Connection variable = new DBConnection\n"
+ "// variable = new DBConnection";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}