// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\s*//.*)(*SKIP)(*F)|^(?:\s*Connection\s+)?(.+?)\s*=\s*new\s+DBConnection").unwrap();
let string = "Connection variable = new DBConnection
variable = new DBConnection
//
//Connection variable = new DBConnection
//variable = new DBConnection
// Connection variable = new DBConnection
// variable = new DBConnection";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}