$re = '~^(\s*//.*)(*SKIP)(*F)|^(?:\s*Connection\s+)?(.+?)\s*=\s*new\s+DBConnection~m';
$str = 'Connection variable = new DBConnection
variable = new DBConnection
//
//Connection variable = new DBConnection
//variable = new DBConnection
// Connection variable = new DBConnection
// variable = new DBConnection';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);