#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?[1-9]?\d(?:\.\d)?$"
Local $sString = "1" & @CRLF & _
"1.1" & @CRLF & _
"01.1" & @CRLF & _
"01" & @CRLF & _
"11" & @CRLF & _
"11.1" & @CRLF & _
"0" & @CRLF & _
"0.1" & @CRLF & _
"00.1" & @CRLF & _
"11.1" & @CRLF & _
"1." & @CRLF & _
"-9" & @CRLF & _
"-0.9" & @CRLF & _
"-100" & @CRLF & _
"100" & @CRLF & _
"-99"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")