// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^-?[1-9]?\d(?:\.\d)?$").unwrap();
let string = "1
1.1
01.1
01
11
11.1
0
0.1
00.1
11.1
1.
-9
-0.9
-100
100
-99";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}