re = /^-?[1-9]?\d(?:\.\d)?$/m
str = '1
1.1
01.1
01
11
11.1
0
0.1
00.1
11.1
1.
-9
-0.9
-100
100
-99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end