#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*Räume(?:\.\w*){1,2}$"
Local $sString = "0_userdata.0.Räume.Wohnzimmer" & @CRLF & _
"0_userdata.0.Räume.Wohnzimmer.H2" & @CRLF & _
"0_userdata.0.Räume.control.Test.Test2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")