using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*Räume(?:\.\w*){1,2}$";
string input = @"0_userdata.0.Räume.Wohnzimmer
0_userdata.0.Räume.Wohnzimmer.H2
0_userdata.0.Räume.control.Test.Test2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}