// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*Räume(?:\.\w*){1,2}$").unwrap();
let string = "0_userdata.0.Räume.Wohnzimmer
0_userdata.0.Räume.Wohnzimmer.H2
0_userdata.0.Räume.control.Test.Test2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}