package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*Räume(?:\.\w*){1,2}$`)
var str = `0_userdata.0.Räume.Wohnzimmer
0_userdata.0.Räume.Wohnzimmer.H2
0_userdata.0.Räume.control.Test.Test2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}