using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0(\.[0-9]+)?$|^[1-9][0-9]*(\.[0-9]+)?$";
string input = @"0
1
01
01.1
1.1
11.1234
5123
1351523.123
0.1234
0.0
0.000
0.00001
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}