import re
regex = re.compile(r"^0(\.[0-9]+)?$|^[1-9][0-9]*(\.[0-9]+)?$", flags=re.MULTILINE)
test_str = ("0\n"
"1\n"
"01\n"
"01.1\n"
"1.1\n"
"11.1234\n"
"5123\n"
"1351523.123\n"
"0.1234\n"
"0.0\n"
"0.000\n"
"0.00001\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")