import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0(\\.[0-9]+)?$|^[1-9][0-9]*(\\.[0-9]+)?$";
final String string = "0\n"
+ "1\n"
+ "01\n"
+ "01.1\n"
+ "1.1\n"
+ "11.1234\n"
+ "5123\n"
+ "1351523.123\n"
+ "0.1234\n"
+ "0.0\n"
+ "0.000\n"
+ "0.00001\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}