# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\(?=[\W\d]|$)//gm;t' <<< "hello \+ \\\world \+ \\\\ this \234 \ is \Pattern\"