use strict;
my $str = 'hello \\+ \\\\\\world \\+ \\\\\\\\ this \\234 \\ is \\Pattern\\';
my $regex = qr/\\(?=[\W\d]|$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";