re = /\\(?=[\W\d]|$)/m
str = 'hello \\+ \\\\\\world \\+ \\\\\\\\ this \\234 \\ is \\Pattern\\'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result