$re = '/\\\\(?=[\W\d]|$)/m';
$str = 'hello \\+ \\\\\\world \\+ \\\\\\\\ this \\234 \\ is \\Pattern\\';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;