using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\(?=[\W\d]|$)";
string substitution = @"";
string input = @"hello \+ \\\world \+ \\\\ this \234 \ is \Pattern\";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}