use strict;
my $str = '98d 01h 23m 45s
01d 02h 03m 04s
02h 03m 04s
03m 04s
04s';
my $regex = qr/(?:(?:(?:0*(\d+)d\s)?0*(\d+)h\s)?0*(\d+)m\s)?0*(\d+)s/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}