import re
regex = re.compile(r"(?:(?:(?:0*(\d+)d\s)?0*(\d+)h\s)?0*(\d+)m\s)?0*(\d+)s", flags=re.MULTILINE)
test_str = ("98d 01h 23m 45s\n"
"01d 02h 03m 04s\n"
"02h 03m 04s\n"
"03m 04s\n"
"04s")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")