re = /(?:(?:(?:0*(\d+)d\s)?0*(\d+)h\s)?0*(\d+)m\s)?0*(\d+)s/m
str = '98d 01h 23m 45s
01d 02h 03m 04s
02h 03m 04s
03m 04s
04s'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end