# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Column\s*;)\s*(;\s*DataSource=([^}]+))/$1$3$2/gm;t' <<< " { 1000000003;1;Column; ;
DataSource=Search Name }
{ 10000004;1;Column; ;
DataSource=Name 2 }
"