$re = '/(Column\s*;)\s*(;\s*DataSource=([^}]+))/m';
$str = ' { 1000000003;1;Column; ;
DataSource=Search Name }
{ 10000004;1;Column; ;
DataSource=Name 2 }
';
$subst = "$1$3$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;