package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Column\s*;)\s*(;\s*DataSource=([^}]+))`)
var str = ` { 1000000003;1;Column; ;
DataSource=Search Name }
{ 10000004;1;Column; ;
DataSource=Name 2 }
`
var substitution = "$1$3$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}