use strict;
my $str = ' { 1000000003;1;Column; ;
DataSource=Search Name }
{ 10000004;1;Column; ;
DataSource=Name 2 }
';
my $regex = qr/(Column\s*;)\s*(;\s*DataSource=([^}]+))/mp;
my $subst = '$1$3$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";