#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(Column\s*;)\s*(;\s*DataSource=([^}]+))"
Local $sString = " { 1000000003;1;Column; ;" & @CRLF & _
" DataSource=Search Name }" & @CRLF & _
"" & @CRLF & _
" { 10000004;1;Column; ;" & @CRLF & _
" DataSource=Name 2 }" & @CRLF & _
""
Local $sSubst = "$1$3$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)