import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?\\d+$";
final String string = "-1234\n"
+ "543\n"
+ "51.23\n"
+ "-512.345612\n"
+ "-5.1-2\n"
+ "-5.-2\n"
+ "5.1.2\n"
+ "51foo51\n"
+ "foo1\n"
+ "1foo\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}