re = /^-?\d+$/m
str = '-1234
543
51.23
-512.345612
-5.1-2
-5.-2
5.1.2
51foo51
foo1
1foo
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end